Resolved
Increased latency

Started
December 09, 2023 at 10:02 PM
Status
Resolved after 10 minutes

Impact

Degraded performance
Affected
Website
  • Resolved
    Resolved

    Latency on requests to cohost.org has returned to normal!

  • Investigating
    Investigating

    We are seeing increased latency for requests to cohost.org. We are investigating the issue to determine a cause.