Resolved
Increased latency

Started
March 09, 2023 at 6:55 AM
Status
Resolved after about 1 hour

Impact

Degraded performance
Affected
Website
  • Resolved

    Latency on requests to cohost.org has returned to normal!

  • Investigating

    We are seeing increased latency for requests to cohost.org. We are investigating the issue to determine a cause.